1С 8.3 Журнал регистрации - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Журнал регистрации

Данные > Примеры кода 1С > 1С 8.3 Журнал регистрации
Реклама:
Журнал регистрации в 1С 8.3 - это реестр записей представленных в хронологическом порядке. Используется для хранения и чтения истории работы пользователя в конфигурации 1С. Доступен:
  • В режиме 1С:Предприятие в Меню -> Администрирование -> Обслуживание -> Журнал регистрации.
  • В режиме Конфигуратор в Меню -> Администрирование -> Журнал регистрации.
При выгрузке БД журнал не сохраняется. Он не храниться в базе данных, а находиться в её каталоге в подпапке 1Cv8Log в файле 1Cv8.lgf - если база файловая, "C:\Program Files\1cv8\srvinfo\<БД>\1Cv8Log" - если база расположена на сервере SQL. Работа с журналом регистрации также возможна и в программной среде 1С 8.3. Настройки регистрации в журнале следует выполнять при включенном монопольном режиме. Если изменения настроек регистрации выполнено в текущем сеансе, то они применятся только после перезапуска всех активных сеансов БД.
Управление уровнем детализации сообщений в журнале регистрации в 1С 8.3:
&НаСервере
Процедура УправлениеУровнемДетализацииСообщений()

   
// Регистрация всех событий журнала
   
УровниЖурнРегистр = Новый Массив;
   
УровниЖурнРегистр.Добавить(УровеньЖурналаРегистрации.Ошибка);
   
УровниЖурнРегистр.Добавить(УровеньЖурналаРегистрации.Информация);
   
УровниЖурнРегистр.Добавить(УровеньЖурналаРегистрации.Предупреждение);
   
УровниЖурнРегистр.Добавить(УровеньЖурналаРегистрации.Примечание);
   
УстановитьИспользованиеЖурналаРегистрации(УровниЖурнРегистр);

КонецПроцедуры
Управление регистрацией событий в журнале регистрации в 1С 8.3:
&НаСервере
Процедура УправлениеРегистрациейСобытий()

   
// Запись событий журнала рекомендуется включать/выключать с помощью:
    // гл.контекст - ПолучитьИспользованиеСобытияЖурналаРегистрации()
    // гл.контекст - УстановитьИспользованиеСобытияЖурналаРегистрации()

   
ИспользСобытия = Новый ИспользованиеСобытияЖурналаРегистрации(); // Объект
   
ИспользСобытия.Использование = Ложь;
   
// Выключение регистрации события "_Ошибка выполнения_"
   
УстановитьИспользованиеСобытияЖурналаРегистрации("_$PerformError$_", ИспользСобытия);
   
// "_$Access$_.Access_" - Доступ
    // "_$Access$_.AccessDenied_" - Отказ в доступе
    // _$PerformError$_" - Ошибка выполнения
    // УстановитьИспользованиеСобытияЖурналаРегистрации не работает с событиями, связанными с транзакциями

КонецПроцедуры
Настройка параметров события Доступ/Отказ в доступе в журнале регистрации в 1С 8.3:
&НаСервере
Процедура НастройкаПараметровДоступаКСправочнику()

   
Спр_Контрагенты = Новый ОписаниеИспользованияСобытияДоступЖурналаРегистрации();
   
// Объект, доступ к которому будет регистрироваться
   
Спр_Контрагенты.Объект = "Справочник.Контрагенты";
   
// Поля доступа:
   
Спр_Контрагенты.ПоляДоступа.Добавить("УНП");
   
Спр_Контрагенты.ПоляДоступа.Добавить("Адрес.ЮрАдрес");//Табл.часть
    // Поля регистрации:
   
Спр_Контрагенты.ПоляРегистрации.Добавить("УНП");
   
Спр_Контрагенты.ПоляРегистрации.Добавить("Адрес.ПочтАдрес");//Табл.часть

   
АльтерПолей = Новый Массив();
   
АльтерПолей.Добавить("Страна");
   
АльтерПолей.Добавить("Область");
   
АльтерПолей.Добавить("Район");

   
// Для настройки объекта метаданных
   
Спр_Контрагенты.ПоляРегистрации.Добавить(АльтерПолей);
   
НастройкаМетаданных = Новый Массив();
   
НастройкаМетаданных.Добавить(Спр_Контрагенты);

КонецПроцедуры

&НаСервере
Процедура НастройкаПараметровОтказаДоступаКСправочнику()

   
Спр_Контрагенты = Новый ОписаниеИспользованияСобытияОтказВДоступеЖурналаРегистрации();
   
// Объект, доступ к которому будет регистрироваться
   
Спр_Контрагенты.Объект = "Справочник.Контрагенты";
   
// Поля доступа:
   
Спр_Контрагенты.ПоляРегистрации.Добавить("УНП");
   
Спр_Контрагенты.ПоляРегистрации.Добавить("Адрес.ЮрАдрес");
   
АльтерПолей = Новый Массив();
   
АльтерПолей.Добавить("Страна");
   
АльтерПолей.Добавить("Область");
   
АльтерПолей.Добавить("Район");
   
Спр_Контрагенты.ПоляРегистрации.Добавить(АльтерПолей);

КонецПроцедуры

&НаСервере
Процедура НастройкаПараметровДоступаКРегистру()

   
Рег_Сведений = Новый ОписаниеИспользованияСобытияДоступЖурналаРегистрации();
   
// Объект, доступ к которому будет регистрироваться
   
Рег_Сведений.Объект = "РегистрСведений.ВидыЗаключенныхДоговоров";
   
// Поля доступа:
   
Рег_Сведений.ПоляДоступа.Добавить("РентабельностьСделки");
   
// Поля регистрации:
   
Рег_Сведений.ПоляРегистрации.Добавить("Менеджер");

   
// Для настройки объекта метаданных
   
НастройкаМетаданных = Новый Массив();
   
НастройкаМетаданных.Добавить(Рег_Сведений);

КонецПроцедуры
Методы журнала регистрации в 1С 8.3:
&НаСервере
Процедура ДопМетоды()

   
// Если нужно установить отбор по событию, то можно получить список событий,
    // которые есть в данном журнале, а потом выбрать из полученного списка
    // Параметры:
    // Пользователь, Компьютер, ИмяПриложения, Событие, Метаданные,
    // РабочийСервер, ОсновнойIPПорт, ВспомогательныйIPПорт
   
ПолучитьЗначенияОтбораЖурналаРегистрации();// Используется для формирования отбора

   
ПредставлениеСобытияЖурналаРегистрации("_$Access$_.Access_");// Используется для представлений событий
   
СкопироватьЖурналРегистрации(перИмяВходногоФайла, перИмяВыходногоФайла, перФильтр));
   
// Используется для копирования фрагмента журнала с фильтром

КонецПроцедуры
Шаблоны (готовые модели) кода 1С 8.3 с тегом #Журнал регистрации:
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 18.11.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому