1С 8.3 Загрузка колонки в Таблицу значений - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Загрузка колонки в Таблицу значений

Данные > Примеры кода 1С > 1С 8.3 Таблица значений
Реклама:
Загрузка колоноки в Таблицу в 1С 8.3:
Процедура ЗагрузитьКолонкуТаблицы(ТаблицаЗЧ, ЗначенияТаблицы, Колонка, ОчищатьТаблицу = Истина) Экспорт

   //  ТаблицаЗЧ       - ТаблицаЗначений, ТабличнаяЧасть
   //  ЗначенияТаблицы - Массив
   //  Колонка         - Строка
   //  ОчищатьТаблицу  - Булево - Необязательно. По-умолчанию Истина

   Если ОчищатьТаблицу Тогда
       ТаблицаЗЧ.Очистить();
   КонецЕсли;

   МаксИндексТаблицы = ТаблицаЗЧ.Количество() - 1;
   МаксИндексМассива = ЗначенияТаблицы.Количество() - 1;

   Для ИндексМассива = 0 По МаксИндексМассива Цикл
       Если ИндексМассива > МаксИндексТаблицы Тогда
           Строка = ТаблицаЗЧ.Добавить();
       Иначе
           Строка = ТаблицаЗЧ[ИндексМассива];
       КонецЕсли;
       Строка[Колонка] = ЗначенияТаблицы[ИндексМассива];
   КонецЦикла;

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 15.10.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому