1С 8.3 Выбор периода месяц/год на форме - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Выбор периода месяц/год на форме

Данные > Примеры кода 1С > 1С 8.3 Форма, элементы
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Выбор периода месяц/год на форме (&НаКлиенте) в 1С 8.3:
&НаКлиенте
Процедура КнВыборПериода(Команда)// создадим на форме кнопку ВыборПериода

   
ВыборПериодаМесяц = Новый ДиалогРедактированияСтандартногоПериода();
   
ВыборПериодаМесяц.Период = Новый СтандартныйПериод;
   
ОповещениеВыбора = Новый ОписаниеОповещения("КнВыборПериодаКонец", ЭтаФорма,
    Новый
Структура("ДиалогВыборПериода", ВыборПериодаМесяц));
   
ВыборПериодаМесяц.Показать(ОповещениеВыбора);

КонецПроцедуры

&НаКлиенте
Процедура КнВыборПериодаКонец(Период, ДопПараметры) Экспорт

   
ВыборПериодаМесяц = ДопПараметры.ДиалогВыборПериода;

    Если
ЗначениеЗаполнено(Период) Тогда
       
ВыбранныйПериод = ВыборПериодаМесяц.Период;
       
НачалоМесяца = НачалоМесяца(ВыбранныйПериод.ДатаНачала);
       
КонецМесяца = КонецМесяца(ВыбранныйПериод.ДатаОкончания);
    КонецЕсли;

КонецПроцедуры
Поиск кода
1
комментарий
Korn
27 май 2021
Благословляю тебя, программист 1С
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 05.03.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому