1С 8.3 Вставить текст в буфер обмена средствами 1С - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Вставить текст в буфер обмена средствами 1С

Данные > Примеры кода 1С > 1С 8.3 Строка, текст, буквы
Реклама:
Платформа 1С 8.3 позволяет работать с буфером обмена с помощью внешней компоненты COMОбъект("HtmlFile") или напрямую через интерфейс, в котором находятся элементы из буфера обмена. Однако из-за параметров безопасности современных операционных систем рекомендую использовать первый вариант.
Вставить текст в буфер обмена с помощью внешней компоненты в 1С 8.3:
Функция Вставить_текст_В_буфер_обмена_с_ВК(ТекстДляВставки) Экспорт // Безопасно (рекомендуется)
    #Если Клиент Тогда

       COM_Объект = Новый COMОбъект("htmlfile");
       COM_Объект.ParentWindow.ClipboardData.Setdata("Text", ТекстДляВставки);
       Возврат ТекстДляВставки;

    #КонецЕсли
КонецФункции
Вставить текст в буфер обмена встроенными средствами в 1С 8.3:
// Не безопасно (ПолеHTMLДокумента не всегда срабатывает, например на Windows 10)
Функция Вставить_текст_В_буфер_обмена(ТекстДляВставки) Экспорт // средствами 1С

   Элементы.Добавить(Тип("ПолеHTMLДокумента"), "Поле_HTML", Ложь);
   ParentWindow = Элементы.Поле_HTML.Документ.ParentWindow;
   ParentWindow.ClipboardData.SetData("Text", ТекстДляВставки);
   // Чистим:
   ЭлементыФормы.Удалить(ЭлементыФормы.Индекс(ЭлементыФормы.Найти("Поле_HTML")));
   Возврат ТекстДляВставки;

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 03.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому