1С 8.3 Удаление (очистка) истории списка ввода - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Удаление (очистка) истории списка ввода

Данные > Примеры кода 1С > 1С 8.3 Форма, элементы
Реклама:
Перейти в раздел примеры кода 1С 8.3:
В справочниках на формах списках есть поле ввода (для быстрого выбора). Данные примеры кода нужны для программной очистки выпадающего списка с ранее вводимыми вариантами. История хранится для каждого пользователя. Кроме программного удаления можно установить признак в поле ввода "История выбора при вводе" - "Не использовать".
Программная очистка истории выпадающего списка выбора в 1С 8.3:
&НаСервере
Процедура Удаление_истории_списка_ввода_Пример1()

   
Юзер = Справочники.Пользователи.Выбрать();
    Пока
Юзер.Следующий() цикл
       
Пользователь_ИБ = ПользователиИнформационнойБазы.НайтиПоУникальномуИдентификатору(Юзер.ИдентификаторПользователяИБ);
        Если
Пользователь_ИБ <> Неопределено Тогда
           
ХранилищеСистемныхНастроек.Удалить("ИсторияВыбора", , Пользователь_ИБ.Имя);
           
//ХранилищеСистемныхНастроек.Удалить("ИсторияВыбора", , ПользовательИБ.Наименование);
       
КонецЕсли;
    КонецЦикла;

КонецПроцедуры
Удаление истории на форме списка выбора в 1С 8.3:
&НаСервере
Процедура Удаление_истории_списка_ввода_Пример2()

   
ЭтаФорма.Элементы.СтрокаПоискаМатериалов.СписокВыбора.Очистить();
   
СписокВыбора.Сохранить("ИсторияПоискаМатериалов", ЭтаФорма.Элементы.СтрокаПоискаМатериалов.СписокВыбора);

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 30.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому