1С 8.3 Таблица Значений Без Null - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Таблица Значений Без Null

Данные > Примеры кода 1С > 1С 8.3 Таблица значений
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Возвращает ТЗ Без Null в 1С 8.3:
Функция ТаблицаЗначений_без_Null(ВходящаяТаблицаЗначений)

   
Копия_ТЗ = Новый ТаблицаЗначений;
    Для Каждого
КолонкаТЗ Из ВходящаяТаблицаЗначений.Колонки Цикл
       
ОписаниеТипа = Новый ОписаниеТипов(КолонкаТЗ.ТипЗначения, ,"NULL");
       
Копия_ТЗ.Колонки.Добавить(КолонкаТЗ.Имя, ОписаниеТипа, КолонкаТЗ.Заголовок, КолонкаТЗ.Ширина);
    КонецЦикла;

    Для Каждого
СтрокаТЗ Из ВходящаяТаблицаЗначений Цикл
       
ЗаполнитьЗначенияСвойств(Копия_ТЗ.Добавить(), СтрокаТЗ);
    КонецЦикла;

    Возврат
Копия_ТЗ; // без Null

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 16.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому