1С 8.3 Свернуть табличную часть - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Свернуть табличную часть

Данные > Примеры кода 1С > 1С 8.3 Документы
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Свернуть табличную часть документа или справочника в 1С 8.3:
Процедура Свернуть_Табличную_Часть(Объект, ИмяТЧ)

   
// Свертка табличной части происходит по аналогии
    // функции у Таблицы значений ТЗ.Свернуть()
    // Объект - должен иметь Табличную часть
    // ИмяТЧ - имя табличной части "строка"

   
Измерения = Новый Массив;
   
Ресурсы   = Новый Массив;

   
КолонкиТЧ = Объект.Метаданные().ТабличныеЧасти[ИмяТЧ].Реквизиты;

    Для Каждого
МетаданныеТЧ Из КолонкиТЧ Цикл
        Если
МетаданныеТЧ.Тип.СодержитТип(Тип("Число")) Тогда
           
Ресурсы.Добавить(МетаданныеТЧ.Имя); // будут суммироваться при свертке табличной части
       
Иначе
           
Измерения.Добавить(МетаданныеТЧ.Имя);
        КонецЕсли;
    КонецЦикла;

   
Объект[ИмяТЧ].Свернуть(СтрСоединить(Измерения, ","),
   
СтрСоединить(Ресурсы, ","));

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 16.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому