1С 8.3 Сортировка списка справочника по реквизиту - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Сортировка списка справочника по реквизиту

Данные > Примеры кода 1С > 1С 8.3 Справочники
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Сортировка справочника по реквизиту в 1С 8.3:
&НаКлиенте
Процедура  СортировкаСпискаСправочникаПоРеквизиту()

   
//Программно отсортируем список справочника Товары по убыванию Розничной цены
    //Перем СписокТоваров;

   
НастройкиПользователя = СписокТоваров.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;

    Для Каждого
ЭлементНастройки Из НастройкиПользователя Цикл
        Если
ТипЗнч(ЭлементНастройки) = ТипЗнч(СписокТоваров.КомпоновщикНастроек.Настройки.Порядок) Тогда
           
ЭлементНастройки.Элементы.Очистить();
           
УсловиеСортировки = ЭлементНастройки.Элементы.Добавить(Тип("ЭлементПорядкаКомпоновкиДанных"));
           
УсловиеСортировки.Поле = Новый ПолеКомпоновкиДанных("РозничнаяЦена");
           
УсловиеСортировки.ТипУпорядочивания = НаправлениеСортировкиКомпоновкиДанных.Убыв;
           
УсловиеСортировки.Использование = Истина;
        КонецЕсли;
    КонецЦикла;

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 25.03.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому