1С 8.3 Сортировка динамического списка - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Сортировка динамического списка

Данные > Примеры кода 1С > 1С 8.3 Динамический список
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Программная сортировка динамического списка в 1С 8.3:
&НаКлиенте
Процедура ПриОткрытии()// формы

   
ЭлементыПользовательскихНастроек = Список.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
    Для Каждого
НастройкаСписка Из ЭлементыПользовательскихНастроек Цикл

        Если
ТипЗнч(НастройкаСписка) = ТипЗнч(Список.КомпоновщикНастроек.Настройки.Порядок) Тогда

           
НастройкаСписка.Элементы.Очистить();
           
// Первая сортировка - по дате документа
           
УсловиеСортировкиДС = НастройкаСписка.Элементы.Добавить(Тип("ЭлементПорядкаКомпоновкиДанных"));
           
УсловиеСортировкиДС.Поле = Новый ПолеКомпоновкиДанных("Дата");
           
УсловиеСортировкиДС.ТипУпорядочивания = НаправлениеСортировкиКомпоновкиДанных.Возр;
           
УсловиеСортировкиДС.Использование = Истина;
           
// Вторая сортировка - по номеру документа
           
УсловиеСортировкиДС = НастройкаСписка.Элементы.Добавить(Тип("ЭлементПорядкаКомпоновкиДанных"));
           
УсловиеСортировкиДС.Поле = Новый ПолеКомпоновкиДанных("Номер");
           
УсловиеСортировкиДС.ТипУпорядочивания = НаправлениеСортировкиКомпоновкиДанных.Возр;
           
УсловиеСортировкиДС.Использование = Истина;
           
// ...
       
КонецЕсли;
    КонецЦикла;

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 25.02.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому