1С 8.3 Соответствие - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Соответствие

Данные > Примеры кода 1С > 1С 8.3 Соответствие
Реклама:
Соответствие в 1С 8.3 - это коллекция пар Ключ (любой тип данных) + Значение (любой тип данных). Ключ всегда - это имя свойства, а значение - само свойство. Обычно используется для хранения небольшого двумерного массива, и передачи между процедурами набора каких-либо параметров.
С соответствием можно работать и в серверном и клиентском контексте. Соответствие в отличии от структуры не упорядочивает элементы при добавлении.
Создание соответствия в 1С 8.3:
&НаКлиенте
Процедура СозданиеСоответствия(Команда)

   
СоотвПараметр = Новый Соответствие;
   
// Ключ (произвольный тип) - Значение (произвольный тип)
   
СоотвПараметр.Вставить("Вид деятельности", "Производство рыбных консервов");
   
СоотвПараметр.Вставить("Дата постановки на учет", '19990328');
   
СоотвПараметр.Вставить("Дата регистрации", '19990417');
   
СоотвПараметр.Вставить("Уставный фонд", 5000);

КонецПроцедуры
Проверка значения на соответствие ключу в 1С 8.3:
&НаКлиенте
Процедура ПроверкаЗначенияНаСоответствиеКлючу(СоотвПараметр)

    Если
СоотвПараметр.Получить("Дата реорганизации") = Неопределено Тогда
       
Сообщить("Реорганизация не производилось");
    КонецЕсли;

КонецПроцедуры
Изменение значения ключа соответствия в 1С 8.3:
&НаКлиенте
Процедура ИзменениеЗначенияКлючаСоответствия(СоотвПараметр)

   
СоотвПараметр.Вставить("Дата первой проверки", '20031104');// 4 ноября 2003г.

КонецПроцедуры
Цикл по всем элементам соответствия в 1С 8.3:
&НаКлиенте
Процедура ЦиклПоВсемЭлементамСоответствия(СоотвПараметр)

    Для Каждого
Элемент Из СоотвПараметр Цикл
       
Сообщить(Строка(Элемент.Ключ) + " / " + Элемент.Значение);// Ключ / Значение
   
КонецЦикла;

КонецПроцедуры
Получение значения соответствия по ключу в 1С 8.3:
&НаКлиенте
Процедура ПолучениеЗначенияСоответствияПоКлючу(СоотвПараметр)

   
Сообщить(СоотвПараметр.Получить("Уставный фонд")); // Сумма уставного фонда 5000

КонецПроцедуры
Получение информации о количестве элементов соответствия в 1С 8.3:
&НаКлиенте
Процедура ИнформацияОКоличествеЭлементовСоответствия(СоотвПараметр)

   
Сообщить(СоотвПараметр.Количество());// 5 (4+1)

КонецПроцедуры
Удаление элементов соответствия в 1С 8.3:
&НаКлиенте
Процедура УдалениеЭлементовСоответствия(СоотвПараметр)

   
// Удаление одного элемента соответствия
   
СоотвПараметр.Удалить("Дата первой проверки");

   
// Удаление всех элементов соответствия
   
СоотвПараметр.Очистить();

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 12.04.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому