1С 8.3 Скопировать текст из буфера обмена средствами 1С - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Скопировать текст из буфера обмена средствами 1С

Данные > Примеры кода 1С > 1С 8.3 Строка, текст, буквы
Реклама:
Платформа 1С 8.3 позволяет работать с буфером обмена с помощью внешней компоненты COMОбъект("HtmlFile") или напрямую через интерфейс, в котором находятся элементы из буфера обмена. Однако из-за параметров безопасности современных операционных систем рекомендую использовать первый вариант.
Скопировать текст из буфера обмена с помощью внешней компоненты в 1С 8.3:
Функция Скопировать_текст_ИЗ_буфера_обмена_с_ВК() Экспорт // Безопасно (рекомендуется)
   #Если Клиент Тогда

       COM_Объект = Новый COMОбъект("htmlfile");
       Возврат COM_Объект.ParentWindow.ClipboardData.Getdata("Text");

    #КонецЕсли
КонецФункции
Скопировать текст из буфера обмена встроенными средствами в 1С 8.3:
// Не безопасно (ПолеHTMLДокумента не всегда срабатывает, например на Windows 10)
Функция Скопировать_текст_ИЗ_буфера_обмена() Экспорт // средствами 1С

   Элементы.Добавить(Тип("ПолеHTMLДокумента"), "Поле_HTML", Ложь);
   ParentWindow = Элементы.Поле_HTML.Документ.ParentWindow;
   // Чистим:
   //Элементы.Удалить(Элементы.Индекс(Элементы.Найти("Поле_HTML")));
   Возврат ParentWindow.ClipboardData.GetData("Text");

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 03.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому