1С 8.3 Склонение по падежам - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Склонение по падежам

Данные > Примеры кода 1С > 1С 8.3 Строка, текст, буквы
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Склонение ФИО, числа, слова по падежам в 1С 8.3:
&НаСервере
Процедура Склонение()

   
// доступна с версии 8.3.13
   
ФИО_Падеж = ПолучитьСклоненияСтроки("Ковалевская Софья Васильевна", "Л=ru_RU;ПЛ=Женский", "ПД=Творительный");
   
// ПД: Именительный, Родительный, Дательный, Винительный, Творительный, Предложный
   
Для Индекс = 0 По ФИО_Падеж.Количество() - 1 Цикл
       
Сообщить(ФИО_Падеж[Индекс]); // Ковалевской Софьей Васильевной
   
КонецЦикла;

   
// доступна с версии 8.3.14
   
Число_Падеж = ПолучитьСклоненияСтрокиПоЧислу("золото", 2.75, "килограмм, грамм, 2", "ЧС=Количественное", "ПД=Предложный; ПЧ=ЧислоПрописью");
    Для
Индекс = 0 По Число_Падеж.Количество() - 1 Цикл
       
Сообщить(Число_Падеж[Индекс]); // Двух килограммах семидесяти пяти граммах золота
   
КонецЦикла;

   
Число_Падеж = ПолучитьСклоненияСтрокиПоЧислу("человек", 3, "", "ЧС=Порядковое", "ПД=Дательный; ПЧ=ЧислоСОкончанием");
    Для
Индекс = 0 По Число_Падеж.Количество() - 1 Цикл
       
Сообщить(Число_Падеж[Индекс]); // 3-му человеку
   
КонецЦикла;

   
Число_Падеж = ПолучитьСклоненияСтрокиПоЧислу("счастливый утёнок", 13, "", "ЧС=Порядковое", "ПД=Родительный; ПЧ=ЧислоПрописью");
    Для
Индекс = 0 По Число_Падеж.Количество() - 1 Цикл
       
Сообщить(Число_Падеж[Индекс]); // Тринадцатого счастливого утёнка
   
КонецЦикла;

   
Число_Падеж = ПолучитьСклоненияСтрокиПоЧислу("дом", 7, "", "ЧС=Порядковое", "ПД=Винительный; ПЧ=ЧислоСОкончанием");
    Для
Индекс = 0 По Число_Падеж.Количество() - 1 Цикл
       
Сообщить(Число_Падеж[Индекс]); // 7-ой дом
   
КонецЦикла;

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 14.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому