1С 8.3 Сканирование штрих-кода из мобильного приложения - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Сканирование штрих-кода из мобильного приложения

Данные > Примеры кода 1С > 1С 8.3 Штрих-код (barcode)
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Сканирование с мобильного приложения Barcode scanner в 1С 8.3:
&НаКлиенте
Процедура СтартПриложенияДляСканирования()

   
// Заранее скачиваем и устанавливаем Barcode scanner:
    // https://play.google.com/store/apps/details?id=com.google.zxing.client.android

   
#Если МобильноеПриложениеКлиент  Тогда

       
МобПрил = Новый ЗапускПриложенияМобильногоУстройства();
       
МобПрил.Действие="com.google.zxing.client.android.SCAN";
       
МобПрил.Запустить(Истина);

        Для Каждого
ПарСтр Из МобПрил.ДополнительныеДанные Цикл

            Если
СокрЛП(ПарСтр.Ключ) = "SCAN_RESULT" Тогда
               
выб_ШтрихКод = ПарСтр.Значение;

               
выб_Стр = ОбщегоНазначенияСервер.ПолучитьОбъектПоШтрихКоду(выб_ШтрихКод);
                Если
выб_Стр = Неопределено Тогда
                   
Сообщить("По штрих-коду объект не найден");
                   
выб_Товар = Неопределено;
                Иначе
                   
выб_Товар = выб_Стр.Товар;
                   
ОткрытьЗначение(выб_Товар);
                КонецЕсли;
            КонецЕсли;
        КонецЦикла;

   
#КонецЕсли

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 29.09.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому