1С 8.3 Регистрация исключений - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Регистрация исключений

Данные > Примеры кода 1С > 1С 8.3 Журнал регистрации
Реклама:
Многие не знают, что перехват исключения с помощью оператора Попытка...Исключение, отключает запись исключения в журнале регистрации. Поэтому, если вам приходится перехватывать исключения чтобы не остановить выполнение программы (например при обработке большого массива несвязанных объектов), то позаботьтесь о регистрации исключений самостоятельно. В данном упрощенном примере выполняется проведение документов в попытке (внутри класса-обертки "Документ" запись идет через классическую попытку). В случае ошибок выполняется регистрация ошибки в ЖР и вывод сообщения пользователю.
//by https://t.me/OneSCast
Запись исключения в 1С 8.3:
Процедура РегистрацияИсключения(ДокументыКОбработке) Экспорт

   Для Каждого Документ Из ДокументыКОбработке Цикл
       Если Не Документ.Провести() Тогда
           РегистрацияОшибки(Документ.Объект, Документ.ИнформацияОбОшибке());
           Сообщить(Документ.ПредставлениеОшибки());
       КонецЕсли;
   КонецЦикла;

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 05.08.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому