1С 8.3 Разложить Массив по типам объектов (в Структуру) - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Разложить Массив по типам объектов (в Структуру)

Данные > Примеры кода 1С > 1С 8.3 Массив
Реклама:
Перейти в основной раздел:
Разложить Массив в Структуру по типам объектов в 1С 8.3:
Функция Разложить_массив_по_типам_объектов(Массив) Экспорт // Массив в структуру (по типам объектов)

   ТипыСтр = Новый Структура;

   Для Каждого ОбъектМ Из Массив Цикл

       МетаданныеДокумента = Метаданные.НайтиПоТипу(ТипЗнч(ОбъектМ));

       Если МетаданныеДокумента <> Неопределено Тогда

           ДокументИмя = МетаданныеДокумента.Имя;

           Если НЕ ТипыСтр.Свойство(ДокументИмя) Тогда
              Документы     = Новый Массив;
               ТипыСтр.Вставить(ДокументИмя, Документы);
           КонецЕсли;

           ТипыСтр[ДокументИмя].Добавить(ОбъектМ);

       КонецЕсли;

   КонецЦикла;

   Возврат ТипыСтр;

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 09.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому