1С 8.3 Пустое перечисление - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Пустое перечисление

Данные > Примеры кода 1С > 1С 8.3 Перечисления
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Проверка на пустое перечисление в коде 1С 8.3:
&НаСервере
Процедура ПустоеПеречисление()

    Если
ПеречислениеВидыЗанятости <> Значение(Перечисление.ВидыЗанятости.ПустаяСсылка) Тогда
       
//...
   
КонецЕсли;

   
//Вариант для реквизита : ЗначениеЗаполнено(ПеречислениеВидыЗанятости):

КонецПроцедуры
Проверка на пустое перечисление в запросе 1С 8.3:
&НаСервере
Процедура ПустоеПеречислениеВЗапросе()

   
Запрос = Новый Запрос;
   
Запрос.Текст = "ВЫБРАТЬ
    |   Кадры.ВидЗанятости КАК ВидЗанятости
    |ИЗ
    |   РегистрСведений.КадроваяИсторияСотрудников КАК Кадры
    |ГДЕ
    |   ВидЗанятости <> &ПустойВидЗанятости"
;

   
Запрос.УстановитьПараметр("ПустойВидЗанятости",Значение(Перечисление.ВидыЗанятости.ПустаяСсылка));
   
РезультатЗапроса = Запрос.Выполнить();

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 09.02.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому