1С 8.3 Проверка на наличие числа в строке - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Проверка на наличие числа в строке

Данные > Примеры кода 1С > 1С 8.3 Строка, текст, буквы
Реклама:
Проверка на наличие числа в строке в 1С 8.3:
&НаКлиенте
Функция ПроверкаНаНаличиеЧислаВСтроке(пСтрока)

   
ЭтоЧисло = Истина;
   
ДлинаСтроки = СтрДлина(пСтрока);

    Для
А = 1 По ДлинаСтроки Цикл

       
стрСимвол = Лев(пСтрока, 1);
       
пСтрока = Сред(пСтрока, 2);

        Если Не (
стрСимвол = "1" или стрСимвол = "2" или стрСимвол = "3" или стрСимвол = "4" или стрСимвол = "5"
           
или стрСимвол = "6" или стрСимвол = "7" или стрСимвол = "8" или стрСимвол = "9" или стрСимвол = "0") Тогда
           
ЭтоЧисло = Ложь;
            Прервать;
        КонецЕсли;

    КонецЦикла;

    Возврат
ЭтоЧисло;//Истина - есть число в строке, Ложь - число в строке отсутствует

КонецФункции // ЭтоЧисло
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 19.04.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому