1С 8.3 Просмотр данных временных таблиц запроса - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Просмотр данных временных таблиц запроса

Данные > Примеры кода 1С > 1С 8.3 Запросы
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Пример №1: Получить содержимое временных таблиц запросов в 1С 8.3:
&НаСервере
Функция ПросмотрДанныхВременныхТаблицЗапроса_1(Запрос, НомерВременнойТаблицы)// НомерВременнойТаблицы с 0

   
Возврат Запрос.МенеджерВременныхТаблиц.Таблицы[НомерВременнойТаблицы].ПолучитьДанные().Выгрузить();
   
//Возвращает таблицу значений с данными временной таблицы

КонецФункции
Пример №2: Получить содержимое временных таблиц запросов в 1С 8.3:
&НаСервере
Функция ПросмотрДанныхВременныхТаблицЗапроса_2(Запрос, НомерВременнойТаблицы)// НомерВременнойТаблицы с 0

   
Возврат Запрос.ВыполнитьПакетСПромежуточнымиДанными()[НомерВременнойТаблицы].Выгрузить();
   
//Возвращает таблицу значений с данными временной таблицы

КонецФункции
Пример №3: Получить содержимое временных таблиц запросов в 1С 8.3:
&НаСервере
Функция ПросмотрДанныхВременныхТаблицЗапроса_3(Запрос, НаименованиеВременнойТаблицы)// по имени ВТ

   
Возврат Запрос.МенеджерВременныхТаблиц.Таблицы.Найти(НаименованиеВременнойТаблицы).ПолучитьДанные().Выгрузить();
   
//Возвращает таблицу значений с данными временной таблицы

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 14.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому