1С 8.3 Приложение, система, интерфейс - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Приложение, система, интерфейс

Данные > Примеры кода 1С > 1С 8.3 Приложение, система, интерфейс
Реклама:
Программа 1С 8.3 - это приложение состоящее из платформы и конфигурации, которое предназначено для автоматизации хозяйственной деятельности на предприятии. Платформа используется для запуска и работы с различными конфигурациями. Каждая конфигурация это набор механизмов и данных для определенной системы учёта и/или организационной деятельности предприятия. Кроме встроенных функций и механизмов для работы с данными и прямыми задачами конфигурации, в 1С реализованы дополнительные функции, которые предназначены для облуживания самого приложения.
Получение / изменение заголовка окна в 1С 8.3:
&НаКлиенте
Процедура ПолучениеИзменениеЗаголовкаОкна(Команда)

   
ПерваяЧасть_короткая_Префикс=ПолучитьКраткийЗаголовокПриложения(); // Часто пустой
   
ВтораяЧасть_длинная=ПолучитьЗаголовокКлиентскогоПриложения(); // Название конфигурации, например ЗУП 3.1

    // Переименуем в новый заголовок  - ЗУП3.Акваферма
   
УстановитьКраткийЗаголовокПриложения("ЗУП3");
   
УстановитьЗаголовокКлиентскогоПриложения("Акваферма");

КонецПроцедуры
Получение варианта интерфейса в 1С 8.3:
&НаКлиенте
Процедура ПолучениеВариантаИнтерфейса(Команда)

   
ТекИнтерфейс=ТекущийВариантИнтерфейсаКлиентскогоПриложения(); // например, Версия8_3

КонецПроцедуры
Получение текущего размера основного шрифта в 1С 8.3:
&НаКлиенте
Процедура ПолучениеТекущегоРазмераОсновногоШрифта(Команда)

   
ТекОснШрифт=ТекущийВариантОсновногоШрифтаКлиентскогоПриложения(); // Обычный или Крупный

КонецПроцедуры
Подключение / отключение обработчика ожидания (УФ) в 1С 8.3:
&НаКлиенте
Процедура ПодключениеОтключениеОбработчикаОжидания(Команда)

   
// *** Подключение обработчика ожидания
   
ПодключитьОбработчикОжидания("ПечатьЗаказНаряда", 7, Истина);

   
// *** Отключение обработчика ожидания
   
ОтключитьОбработчикОжидания("ПечатьЗаказНаряда");

КонецПроцедуры

&НаКлиенте
Процедура ПечатьЗаказНаряда()

   
ТабДок = Новый ТабличныйДокумент;
   
Макет = Документы.ЗаказНаряд.ПолучитьМакет("Печать");

   
МакетДок = Макет.ПолучитьОбласть("МакетДок");
   
МакетДок.Параметры.Заполнить(ЭтотОбъект);
   
ТабДок.Вывести(МакетДок);

   
ТабДок.Показать();

КонецПроцедуры
Подключение / отключение глобального обработчика оповещения в 1С 8.3:
&НаКлиенте
Процедура ПодключениеОтключениеГлобальногоОбработчикаОповещения(Команда)

   
// *** Подключение обработчика ожидания экспортируемой процедуры
    // из модуля управляемого приложения (можно располагать и в одном из общих модулей)
   
ПодключитьОбработчикОповещения("глОбработкаОповещения");

   
// Тест процедуры
   
Оповестить("СоединениеСКерио", "ВерсияКонтроля4", ЭтаФорма);

   
// *** Отключение обработчика оповещения
   
ОтключитьОбработчикОповещения("глОбработкаОповещения");

КонецПроцедуры
Получение текущего режим запуска в 1С 8.3:
&НаКлиенте
Процедура ПолучениеТекущегоРежимЗапуска(Команда)

   
ТекРежимЗапуска=ТекущийРежимЗапуска();
   
// Авто, ОбычноеПриложение, УправляемоеПриложение, Неопределено (Внешнее соединение)

КонецПроцедуры
Получение скорости клиентского соединения в 1С 8.3:
&НаКлиенте
Процедура ПолучениеСкоростиКлиентскогоСоединения(Команда)

   
СкоростьСоединения=ПолучитьСкоростьКлиентскогоСоединения(); // Низкая или Обычная

КонецПроцедуры
Получение строки соединения информационной базы в 1С 8.3:
&НаКлиенте
Процедура ПолучениеСтрокиСоединенияИБ(Команда)

   
Сообщить(СтрокаСоединенияИнформационнойБазы()); // Например, File="E:\Base\ERP";

КонецПроцедуры
Завершение работы системы (с обработчиком закрытия) в 1С 8.3:
&НаКлиенте
Процедура ЗавершениеРаботыСистемы(Команда)

   
ЗавершитьРаботуСистемы(Истина,Ложь,"");
   
// Параметры:
    // Запрашивать возможность
    // Перезапустить после завершения (необ.)
    // Дополнительные параметры, если делается перезапуск (необ.)

КонецПроцедуры
Завершение работы системы (без обработчика закрытия) в 1С 8.3:
&НаКлиенте
Процедура ПрекращениеРаботыСистемы(Команда)

   
ПрекратитьРаботуСистемы(Ложь, "");
   
// Параметры:
    // Перезапустить после завершения (необ.)
    // Дополнительные параметры, если делается перезапуск (необ.)

КонецПроцедуры
Запуск ещё одного экземпляра 1С Предприятия в 1С 8.3:
&НаКлиенте
Процедура ЗапускЕщёОдногоЭкземпляра1СПредприятия(Команда)

   
ЗапуститьСистему("", Истина);

КонецПроцедуры
Получение часового пояса сеанса в 1С 8.3:
&НаСервере
Процедура ПолучениеЧасовогоПоясаСеанса()

   
ЧПС=ЧасовойПоясСеанса(); // Например, Europe/Minsk

КонецПроцедуры
Получение текущей даты сеанса в 1С 8.3:
&НаСервере
Процедура ПолучениеТекущейДатыСеанса()

   
ТДС=ТекущаяДатаСеанса(); // Например, 24.05.2017 20:16:18

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 25.05.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому