1С 8.3 Преобразование Фамилия Имя Отчество в Фамилия и инициалы - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Преобразование Фамилия Имя Отчество в Фамилия и инициалы

Данные > Примеры кода 1С > 1С 8.3 Строка, текст, буквы
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Пример №1: Разложить ФИО на Фамилия и инициалы в 1С 8.3:
&НаКлиенте
Процедура ФИО_Инициалы_1()

   
// Получим из Фамилия Имя Отчество => Фамилия И.О.
   
ФИО_Руководителя = "Жуков Георгий Константинович";
   
Сообщить("Преобразуем: "+ФИО_Руководителя);

    Пока
Найти(ФИО_Руководителя, "  ") <> 0 Цикл
       
ФИО_Руководителя = СтрЗаменить(ФИО_Руководителя,"  "," ");
    КонецЦикла;

   
ФИО_Руководителя = СтрЗаменить(ФИО_Руководителя," ",Символы.ПС);
   
Сообщить("в: "+СтрПолучитьСтроку(ФИО_Руководителя,1)+" "+Лев(СтрПолучитьСтроку(ФИО_Руководителя,2),1)
    +
"."+Лев(СтрПолучитьСтроку(ФИО_Руководителя,3),1) + ".");
   
// в: Жуков Г.К.

КонецПроцедуры
Пример №2: Разложить ФИО на Фамилия и инициалы в 1С 8.3:
&НаКлиенте
Процедура ФИО_Инициалы_2()

   
// Получим из Фамилия Имя Отчество => Фамилия И.О.
   
ФИО_Руководителя = "Жуков Георгий Константинович";
   
Сообщить("Преобразуем: "+ФИО_Руководителя);

   
Инициал_Имя = СтрНайти(ФИО_Руководителя, " ") + 1;
   
Инициал_Имя = Сред(ФИО_Руководителя, Инициал_Имя, 1);

   
Инициал_Отчество = СтрНайти(ФИО_Руководителя, " ", НаправлениеПоиска.СКонца) + 1;
   
Инициал_Отчество = Сред(ФИО_Руководителя, Инициал_Отчество, 1);

   
Полностью_Фамилия = СокрЛП(Лев(ФИО_Руководителя, СтрНайти(ФИО_Руководителя, " ")));

   
Сообщить("в: "+Полностью_Фамилия+" "+Инициал_Имя+"."+Инициал_Отчество+".");
   
// в: Жуков Г.К.

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 14.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому