1С 8.3 Предупреждение по центру экрана - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Предупреждение по центру экрана

Данные > Примеры кода 1С > 1С 8.3 Диалоги
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Вывод предупреждения пользователю по центру экрана в 1С 8.3:
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

   ТекстНаЭкран = СформироватьТекстПредупреждения();
   Если ТекстНаЭкран <> "" Тогда
       ОписаниеОповещения = Новый ОписаниеОповещения("ПредупреждениеЗавершение",ЭтаФорма);
       ПоказатьПредупреждение(ОписаниеОповещения, ТекстНаЭкран,, "ВНИМАНИЕ");
   КонецЕсли;

КонецПроцедуры

&НаСервере
Функция СформироватьТекстПредупреждения()

   ТекстНаЭкран = "";
   Для Каждого Стр Из Объект.Страны Цикл
       Если Стр.Страна.Европа Тогда
           ТекстНаЭкран = ТекстНаЭкран + "Страна " + Строка(Стр.Страна)
           + " в " + Строка(Стр.НомерСтроки)
           +    " строке, относится к части света Европа!" + Символы.ПС;
       КонецЕсли;
   КонецЦикла;

   Возврат ТекстНаЭкран;

КонецФункции

&НаКлиенте
Процедура ПредупреждениеЗавершение(Параметры) Экспорт
      //Обработка закрытия предупреждения
КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 17.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому