1С 8.3 Поместить Таблицу Значений во временную таблицу Запроса - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Поместить Таблицу Значений во временную таблицу Запроса

Данные > Примеры кода 1С > 1С 8.3 Таблица значений
Реклама:
Типизация колонок Таблицы значений в 1С 8.3:
Процедура ПоместитьТаблицуЗначенийВЗапрос(Запрос, ТаблицаЗначений,  ИмяВременнойТаблицыВЗапросе) Экспорт

   ТипизированнаяТЗ = Типизация_колонок_ТЗ(ТаблицаЗначений);
   // Типизация_колонок_ТЗ - https://1cnik.by/tipizacija_kolonok_tablicy_znachenij.php

   ТекстЗапроса = Запрос.Текст;
   Запрос.Текст = "Выбрать * Поместить " + ИмяВременнойТаблицыВЗапросе +
  " Из &" + ИмяВременнойТаблицыВЗапросе + " как " + ИмяВременнойТаблицыВЗапросе;

   Если Запрос.МенеджерВременныхТаблиц = Неопределено Тогда // доп.проверка
       Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
   КонецЕсли;

   Если Запрос.Параметры.Свойство(ИмяВременнойТаблицыВЗапросе) Тогда
       ПараметрВременнойТаблицыВЗапросе =  Запрос.Параметры.ИмяВременнойТаблицыВЗапросе;
       Запрос.УстановитьПараметр(ИмяВременнойТаблицыВЗапросе, ТипизированнаяТЗ);
       Запрос.Выполнить();
       Запрос.УстановитьПараметр(ИмяВременнойТаблицыВЗапросе, ПараметрВременнойТаблицыВЗапросе);
   Иначе
       Запрос.УстановитьПараметр(ИмяВременнойТаблицыВЗапросе, ТипизированнаяТЗ);
       Запрос.Выполнить();
       Запрос.Параметры.Удалить(ИмяВременнойТаблицыВЗапросе);
   КонецЕсли;

   Запрос.Текст = ТекстЗапроса;

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 15.10.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому