1С 8.3 Получить список действующих пользователей - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Получить список действующих пользователей

Данные > Примеры кода 1С > 1С 8.3 Пользователи, роли (права) доступа
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Программно получить сохраненные пароли в базе данных 1С 8.3:
&НаСервере
Процедура ПолучитьПользователей(ВсеЮзеры, СписокЮзеров)

   // Добавлена проверка на статус ВходВПрограмму
   // из ХранилищеЗначенийОбъекта (Хранилище Значений Объекта)
   // Производим чтение структуры и проверяем на условие истина(булево)
  СписокВыбрПольз = Параметры.ПользователиСБыстрымДоступом;
  Запрос = Новый Запрос("ВЫБРАТЬ
   |Ссылка ИЗ Справочник.Пользователи
   | ГДЕ НЕ ПометкаУдаления
   | И НЕ Недействителен
   | И НЕ Служебный");

   Выборка = Запрос.Выполнить().Выбрать();
   Пока Выборка.Следующий() Цикл
       Если СписокВыбрПольз.НайтиПоЗначению(Выборка.Ссылка) = Неопределено Тогда
           ПользовательОбъект =  Выборка.Ссылка.Получитьобъект();
           ХранилищеЗн = ПользовательОбъект.СвойстваПользователяИБ;
           ХранилищеЗнПолучить = ХранилищеЗн.Получить();
           Если  НЕ ХранилищеЗнПолучить = Неопределено
               И ХранилищеЗнПолучить.ВходВПрограммуРазрешен Тогда
               ВсеЮзеры.Добавить().Пользователь = Выборка.Ссылка;
           КонецЕсли;
       Иначе
           ПользовательОбъект =  Выборка.Ссылка.Получитьобъект();
           ХранилищеЗн = ПользовательОбъект.СвойстваПользователяИБ;
           ХранилищеЗнПолучить = ХранилищеЗн.Получить();
           Если  НЕ ХранилищеЗнПолучить = Неопределено
               И ХранилищеЗнПолучить.ВходВПрограммуРазрешен Тогда
               СписокЮзеров.Добавить().Пользователь = Выборка.Ссылка;
           КонецЕсли;
       КонецЕсли;
   КонецЦикла;

   ВсеЮзеры.Сортировать("Пользователь Возр");
   СписокЮзеров.Сортировать("Пользователь Возр");

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 17.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому