1С 8.3 Получить сохраненные пароли - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Получить сохраненные пароли

Данные > Примеры кода 1С > 1С 8.3 Пользователи, роли (права) доступа
Реклама:
Программно получить сохраненные пароли в базе данных 1С 8.3:
Функция Получить_сохраненные_пароли() Экспорт // из регистра

    //   Функция позволяет:
    // получить пароль системной учетной записи 1С
    // учетный данные для обмена 1С с интернет магазином
    // внутренний адрес менеджера сервиса
    // пароль интернет поддержки пользователей
    // и другие учетные жданные 1С

   
УстановитьПривилегированныйРежим(Истина);

   
ДанныеСтр = Новый Структура();

   
Запрос = Новый Запрос;
   
Запрос.Текст =
   
"ВЫБРАТЬ
    |   БезопасноеХранилищеДанных.Данные КАК Данные
    |ИЗ
    |   РегистрСведений.БезопасноеХранилищеДанных КАК БезопасноеХранилищеДанных
    |ГДЕ
    |   БезопасноеХранилищеДанных.Владелец = &Владелец"
;

   
//будет выведен не весь список, а по конкретному владельцу
    //Запрос.УстановитьПараметр("Владелец", Владелец);
   
РезультатЗапроса = Запрос.Выполнить().Выбрать();

    Если
РезультатЗапроса.Следующий() Тогда
        Если
ЗначениеЗаполнено(РезультатЗапроса.Данные) Тогда
           
ДанныеИзХранилища = РезультатЗапроса.Данные.Получить();
            Если
ЗначениеЗаполнено(ДанныеИзХранилища) Тогда
               
ЗаполнитьЗначенияСвойств(ДанныеСтр, ДанныеИзХранилища);
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;

   
УстановитьПривилегированныйРежим(Ложь);

    Возврат
ДанныеСтр;

КонецФункции
Получить (через БСП) сохраненные пароли в 1С 8.3:
Процедура Получить_сохраненные_пароли_БСП(IDподсистемы) Экспорт

   
ОбщегоНазначения.ПрочитатьДанныеИзБезопасногоХранилища(IDподсистемы, "Пароль");

КонецПроцедуры
Получить сохраненные пароль и логин ИТС из базы данных в 1С 8.3:
Процедура Получить_сохраненные_пароль_и_логин_ИТС() Экспорт

   
Авторизация = ИнтернетПоддержкаПользователей.ДанныеАутентификацииПользователяИнтернетПоддержки();
   
Логин_авторизация="";
   
Пароль_авторизация="";

    Попытка
        Для Каждого
ЭлементАвторизации Из Авторизация Цикл
           
Сообщить(ЭлементАвторизации.Ключ + " = " + ЭлементАвторизации.Значение);
            Если
ЭлементАвторизации.Ключ = "Логин" Тогда
               
Логин_авторизация = ЭлементАвторизации.Значение;
               
Сообщить("Логин: "+Логин_авторизация);
            ИначеЕсли
ЭлементАвторизации.Ключ = "Пароль" Тогда
               
Пароль_авторизация = ЭлементАвторизации.Значение;
               
Сообщить("Пароль: "+Пароль_авторизация);
            КонецЕсли;
        КонецЦикла;
    Исключение

       
Сообщить("Регистрационные данные ИТС отсутствуют!");
       
//Добавить свои данных в хранилище можно так:
        //ОбщегоНазначения.ЗаписатьДанныеВБезопасноеХранилище(ИнтернетПоддержкаПользователей.ИдентификаторПодсистемы(), "Ваш логин от ИТС", "login");
        //ОбщегоНазначения.ЗаписатьДанныеВБезопасноеХранилище(ИнтернетПоддержкаПользователей.ИдентификаторПодсистемы(), "Ваш Пароль от ИТС", "password");

   
КонецПопытки

КонецПроцедуры

Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 12.05.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому