1С 8.3 Получить номер колонки Таблицы Значений - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Получить номер колонки Таблицы Значений

Данные > Примеры кода 1С > 1С 8.3 Таблица значений
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Узнать номер колонки Таблицы значений по её имени в 1С 8.3:
Функция Получить_номер_колонки_ТЗ(ТЗ, ЗначениеПоиска) Экспорт

   
//ЗначениеПоиска = "Цвет";

   
НомерКолонкиТЗ = 0;
    Для Каждого
КолонкаТЗ Из ТЗ.Колонки Цикл

        Если
КолонкаТЗ.Имя = ЗначениеПоиска Тогда
           
НомерКолонкиТЗ = НомерКолонкиТЗ + 1;
            Возврат
НомерКолонкиТЗ;
        КонецЕсли;

    КонецЦикла;

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 30.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому