1С 8.3 Получить количество символов латиницы в строке - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Получить количество символов латиницы в строке

Данные > Примеры кода 1С > 1С 8.3 Строка, текст, буквы
Реклама:
Количество символов латиницы в искомой строке в 1С 8.3:
Функция Получение_Количества_Символов_Латиницы(Знач СтрокаЛатиница) Экспорт

   
Найденные_Символы_Латиницы = Новый Массив;

   
СтрокаЛатиница      = СокрЛП(СтрокаЛатиница);
   
СтрокаЛатиница      = Нрег(СтрокаЛатиница);
   
ДлинаСтрокиЛатиницы = СтрДлина(СтрокаЛатиница);

    Если
ДлинаСтрокиЛатиницы > 0 Тогда

       
СимволыЛатиницы= "abcdefghijklmnopqrstuvxyz";

        Для
СЛ = 1 по ДлинаСтрокиЛатиницы Цикл

           
ТекСимвол = Сред(СтрокаЛатиница,СЛ,1);
            Если 
Найденные_Символы_Латиницы.Найти(ТекСимвол) = Неопределено
                и
СтрНайти("abcdefghijklmnopqrstuvxyz",ТекСимвол) > 0 Тогда
               
Найденные_Символы_Латиницы.Добавить(ТекСимвол);
            КонецЕсли;

        КонецЦикла;

    КонецЕсли;

   
//Возвращает количество найденных различных символов латиницы в строке 1С 8.3
   
Возврат Найденные_Символы_Латиницы.Количество();

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 25.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому