1С 8.3 Получить количество символов кириллицы в строке - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Получить количество символов кириллицы в строке

Данные > Примеры кода 1С > 1С 8.3 Строка, текст, буквы
Реклама:
Количество символов кириллицы в искомой строке в 1С 8.3:
Функция Получение_Количества_Символов_Кириллицы(Знач СтрокаКириллица) Экспорт

   
Найденные_Символы_Кириллицы = Новый Массив;

   
СтрокаКириллица      = СокрЛП(СтрокаКириллица);
   
СтрокаКириллица      = Нрег(СтрокаКириллица);
   
ДлинаСтрокиКириллицы = СтрДлина(СтрокаКириллица);

    Если
ДлинаСтрокиКириллицы > 0 Тогда

       
СимволыКирилицы = "абвгдеёжзийклмнопрстуфхцчшщъыьэюя";

        Для
СК = 1 по ДлинаСтрокиКириллицы Цикл

           
ТекСимвол = Сред(СтрокаКириллица,СК,1);
            Если 
Найденные_Символы_Кириллицы.Найти(ТекСимвол) = Неопределено
                и
СтрНайти("абвгдеёжзийклмнопрстуфхцчшщъыьэюя",ТекСимвол) > 0 Тогда
               
Найденные_Символы_Кириллицы.Добавить(ТекСимвол);
            КонецЕсли;

        КонецЦикла;

    КонецЕсли;

   
//Возвращает количество найденных различных символов кириллицы в строке 1С 8.3
   
Возврат Найденные_Символы_Кириллицы.Количество();

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 25.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому