1С 8.3 Получение имени значения перечисления - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Получение имени значения перечисления

Данные > Примеры кода 1С > 1С 8.3 Перечисления
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Пример №1 Получение имени значения перечисления в 1С 8.3
Функция ИмяЗначенияПеречисления_Пример1(ПеречЗн) Экспорт

   
//ПеречЗн = например: Перечисления.Пол.Женский

   
Если Не ЗначениеЗаполнено(ПеречЗн) Тогда
        Возврат Неопределено;
    КонецЕсли;

    Возврат
XMLстрока(ПеречЗн); // вернет Женский

КонецФункции
Пример №2 Получение имени значения перечисления в 1С 8.3:
Функция ИмяЗначенияПеречисления_Пример2(ПеречЗн) Экспорт

   
//ПеречЗн = например: Перечисления.Пол.Мужской

   
Если Не ЗначениеЗаполнено(ПеречЗн) Тогда
        Возврат Неопределено;
    КонецЕсли;

   
ИмяЗП = Метаданные.Перечисления[ПеречЗн.Метаданные().Имя].
   
ЗначенияПеречисления[Перечисления[ПеречЗн.Метаданные().Имя].Индекс(ПеречЗн)].Имя;

    Возврат
ИмяЗП; // вернет Мужской

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 18.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому