1С 8.3 Планы видов расчета - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Планы видов расчета

Данные > Примеры кода 1С > 1С 8.3 Планы видов расчета
Реклама:
План видов расчета в 1С 8.3 - это прикладные объекты конфигурации, используются для описания видов расчета и их взаимного влияния друг на друга. По своей структуре объект представляется в виде списка и похож на справочник с реквизитами и используется в регистрах расчета. Основное назначение плана видов характеристик состоит в том, чтобы для каждой характеристики хранить определенный тип значения, который она может принимать (строка, число, значение...). Наглядный пример использования плана видов расчета - это Начисления и Удержания в конфигурации ЗУП 3.0РБ/3.1.
Создание элемента План Видов Расчета в 1С 8.3:
&НаСервере
Процедура СозданиеЭлементПланВидовРасчета()

   
Удерж   = ПланыВидовРасчета.УдержанияОрганизаций;
   
Начисл  = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций;

   
ОбъектПланаВР = Удерж.ЗаТоварноМатериальныеЦенности.ПолучитьОбъект();

   
НоваяСтрока = ОбъектПланаВР.БазовыеВидыРасчета.Добавить();
   
НоваяСтрока.ВидРасчета = Начисл.РайонныйКоэффициент;
   
ОбъектПланаВР.Записать();

КонецПроцедуры
Перебор Плана Видов Расчета (в цикле) в 1С 8.3:
&НаСервере
Процедура ПереборПланаВидовРасчетаВЦикле()

   
ВыборкаНачислений = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.Выбрать();  // Начислений
   
Пока ВыборкаНачислений.Следующий() Цикл
       
// Обработчик
   
КонецЦикла;

   
ВыборкаУдержаний = ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.Выбрать();  // Удержаний
   
Пока ВыборкаУдержаний.Следующий() Цикл
       
// Обработчик
   
КонецЦикла;

КонецПроцедуры
Выбор пользователем вида начисления (или удержания) в 1С 8.3:
&НаКлиенте
Процедура ВыборПользователемВидаНачисления()

   
ВидНачисления=Неопределено;

   
Типы = Новый Массив;
   
Типы.Добавить(Тип("ПланВидовРасчетаСсылка.Начисления"));

   
ОписаниеВозмТипов = Новый ОписаниеТипов(Типы);
    Если
ВвестиЗначение(ВидНачисления, "Выберите вид начисления", ОписаниеВозмТипов) Тогда
       
Сообщить("Выбрано начисление: "+ВидНачисления);
       
// Обработчик
   
КонецЕсли;

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 13.10.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому