1С 8.3 Печать PDF Файла средствами 1С - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Печать PDF Файла средствами 1С

Данные > Примеры кода 1С > 1С 8.3 Файлы, каталоги
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Программно распечатать файл в формате PDF из 1С 8.3:
Процедура Печать_PDF_Файла(PDF_File, ИмяУстройства, ОтправитьСразуНаПринтер) Экспорт

   
//Параметры процедуры:
    // PDF_File - полный путь к файлу ПДФ (например: D:\Temp1C_PDF\INPUT.pdf)
    // ИмяУстройства - имя МФУ или принтера в системе
    // ОтправитьСразуНаПринтер - булево (истина-на принтер, ложь-открыть для просмотра)

   
AdobeAR = Новый Файл("C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe");

    Если
AdobeAR.Существует() Тогда

        Если
ОтправитьСразуНаПринтер = Истина Тогда
           
// Параметры командной строки Acrobat Reader:
            // /o - не открывать диалоговое окно приложения
            // /h - открыть приложение и свернуть на панели задач
            // /p - открыть файл в приложении и сразу перейти к диалоговому окну печати
            // /t [ [ []]] - распечатать файл на указанном принтере

           
ЗапуститьПриложение("""" + AdobeAR.ПолноеИмя + """ /o /t """ + PDF_File.ПолноеИмя + """ """ + ИмяУстройства + """");
           
// <директория приложения> /o /t <имя файла> <имя принтера>
       
Иначе
           
ЗапуститьПриложение(PDF_File.ПолноеИмя);//открываем на просмотр средствами ОС
       
КонецЕсли;

    Иначе
       
Сообщить("Не установлен Acrobat Reader DC! Печать невозможна!");
       
ЗапуститьПриложение(PDF_File.ПолноеИмя);//открываем на просмотр средствами ОС
   
КонецЕсли;

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 30.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому