1С 8.3 Параметры в навигационных ссылках - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Параметры в навигационных ссылках

Реклама:
Перейти в раздел примеры кода 1С 8.3:
Доп.параметры в навигационных ссылках в 1С 8.3:
// Получения навигационной ссылки - форма который открывается по системной кнопке Получить ссылку (или Ctrl + F11).
// 1С 8.3.19 поддерживает автоматическое формирование и обработку навигационных ссылок с дополнительными параметрами
// для отчетов (настроек) и форм с динамическими списками (настройки и текущая строка). Соответствующие обработчики
// форм: ОбработкаПолученияСпискаНавигационныхСсылок и ОбработкаПолученияНавигационнойСсылки.

Процедура ОбработкаПолученияСпискаНавигационныхСсылок(СписокНавигационыхСсылок, КлючПоУмолчанию)

   
// Вызывается перед показом системного диалога получения навигационной ссылки
   
СписокНавигационыхСсылок.Добавить("ВсяВходящаяКорреспонденция", "Вся входящая корреспонденция");
   
СписокНавигационыхСсылок.Добавить("ИзбраннаяКорреспонденция", "Избранная корреспонденция");
   
СписокНавигационыхСсылок.Добавить("Спам", "Спам");

КонецПроцедуры

Процедура
ОбработкаПолученияНавигационнойСсылки(Ключ, Представление, НавигационнаяСсылка, СтандартнаяОбработка)

   
// Значение возвращаемой навигационной ссылки в зависимости от ключа
   
Если Ключ = "ВсяВходящаяКорреспонденция" Тогда
       
НавигационнаяСсылка = ПолучитьНавигационнуюСсылку(Метаданные.Документы.Письма, НастройкиВходПочты);
       
СтандартнаяОбработка = Ложь;
    ИначеЕсли
Ключ = "ИзбраннаяКорреспонденция" Тогда
       
НавигационнаяСсылка = ПолучитьНавигационнуюСсылку(Метаданные.Документы.Письма, НастройкиПриоритетнойПочты);
       
СтандартнаяОбработка = Ложь;
    ИначеЕсли
Ключ = "Спам" Тогда
       
НавигационнаяСсылка = ПолучитьНавигационнуюСсылку(Метаданные.Документы.Письма, НастройкиДляСпама);
       
СтандартнаяОбработка = Ложь;
    КонецЕсли;

КонецПроцедуры
Пример использования доп.параметров в навиг.ссылках в 1С 8.3:
//Методы для формирования навигационных ссылок с дополнительными параметрами в расширениях соотвествующих типов:
//   ПолучитьНавигационнуюСсылкуОтчета
//   ПолучитьНавигационнуюСсылкуТекущегоВариантаОтчета
//   ПолучитьНавигационнуюСсылкуТекущихНастроекОтчета
//   ПолучитьНавигационнуюСсылкуОбработки
//   ПолучитьНавигационнуюСсылкуСписка
//   ПолучитьНавигационнуюСсылкуТекущихНастроекСписка
//   ПолучитьНавигационнуюСсылкуОбъекта
//   ПолучитьНавигационнуюСсылкуЗаписи

//Параметры метода (необ.):
//   ПредставлениеНавигационнойСсылки (строка). Представление, кот.будет помещено в хранилище внешних данных навиг.ссылок
//   ВнешниеДанныеНавигационнойСсылки (структура). Сюда можно поместить любые необходимые данные.


// Главный бухгалтер отправляет бухгалтеру ссылку на документ "Амортизация ОС"
// с ссылкой на определенное основное средство:
Процедура ОбработкаПолученияСпискаНавигационныхСсылок(СписокНавигационыхСсылокКлючПоУмолчанию)

   
СписокНавигационыхСсылок.Добавить("СсылкаОсновноеСредство", "Ссылка на основное средство");

КонецПроцедуры

Процедура
ОбработкаПолученияНавигационнойСсылки(Ключ, Представление, НавигационнаяСсылка, СтандартнаяОбработка)

    Если
Ключ = "СсылкаОсновноеСредство" Тогда

       
СтандартнаяОбработка = Ложь;
       
ОтборОС = Новый Структура("СсылкаОС", Элементы.ОсновныеСредства.ТекущаяСтрока);
       
НавигационнаяСсылка = ПолучитьНавигационнуюСсылкуОбъекта(Представление, ОтборОС);

    КонецЕсли;

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 04.11.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому