1С 8.3 Оставить в строке только числа - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Оставить в строке только числа

Данные > Примеры кода 1С > 1С 8.3 Строка, текст, буквы
Реклама:
В строке оставить только числа в 1С 8.3:
&НаКлиенте
Функция ТолькоЧисла(СтрокаРазличныеСимволы)

    Если
СтрДлина(СтрокаРазличныеСимволы) = 0 Тогда
        Возврат
"";
    КонецЕсли;

   
РезультатЧисло = "";
    Для
а = 1 по СтрДлина(СтрокаРазличныеСимволы) Цикл
       
Символ = Сред(СтрокаРазличныеСимволы, а, 1);

        Если
Найти("0123456789", Символ) = 0 Тогда
            Продолжить;
        КонецЕсли;

       
РезультатЧисло = "" + РезультатЧисло + Символ;
    КонецЦикла;

    Возврат
РезультатЧисло;

КонецФункции

&НаКлиенте
Процедура ОставитьВСтрокеТолькоЧисла()

   
ПреобразованнаяСтрокаВТолькоЧисла=ТолькоЧисла(тестСтрока);
   
Сообщить("Строка (только числа) ="+ПреобразованнаяСтрокаВТолькоЧисла);

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 12.03.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому