1С 8.3 Общие элементы массивов - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Общие элементы массивов

Данные > Примеры кода 1С > 1С 8.3 Массив
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Функция возвращает общие элементы (пересечение) двух массивов.
Общие элементы массивов (от пользователя prog1c) в 1С 8.3:
Функция ОбщиеЭлементыМассивов(Массив1N, Массив2N)

   Результат = Новый Массив;

   Для Каждого ЭлементМассива Из Массив1N Цикл
       Если Массив2N.Найти(ЭлементМассива) <> Неопределено И
               Результат.Найти(ЭлементМассива) = Неопределено Тогда
           Результат.Добавить(ЭлементМассива);
       КонецЕсли;
   КонецЦикла;

   Для Каждого ЭлементМассива Из Массив2N Цикл
       Если Массив1N.Найти(ЭлементМассива) <> Неопределено И
               Результат.Найти(ЭлементМассива) = Неопределено Тогда
           Результат.Добавить(ЭлементМассива);
       КонецЕсли;
   КонецЦикла;

   Возврат Результат;

КонецФункции // ОбщиеЭлементыМассивов()
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 16.07.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому