1С 8.3 Обработка перехода по навигационной ссылке - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Обработка перехода по навигационной ссылке

Данные > Примеры кода 1С > 1С 8.3 Приложение, система, интерфейс
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Запуск мобильного приложения в Android (через механизм намерений) в 1С 8.3:
Процедура Application_Launch(ПараметрN1, ПараметрN2) // с 8.3.18

    // Intent (механизм намерений. Схема "myappfunc://" должна быть указана как поддерживаемая
    // для ОС Android в создаваемом мобильном приложении
   
Старт = Новый ЗапускПриложенияМобильногоУстройства("android.intent.action.VIEW","myappfunc://testPath?key1=" + ПараметрN1);//Число
   
Старт.ДополнительныеДанные.Добавить("key2", ПараметрN2); // Строка
   
Если Старт.ПоддерживаетсяЗапуск() Тогда
       
Старт.Запустить(Ложь);
    КонецЕсли;

КонецПроцедуры
Реакции мобильного приложения на вызов в модуле клиентского приложения в 1С 8.3:
Процедура ОбработкаПереходаПоНавигационнойСсылке(ДанныеПереходаПоНавСсылке, СтандартнаяОбработка) // с 8.3.18

    //  Глубинная ссылка может быть:
    //  1) С использованием собственной схемы (например, myfuncapp://comand?params)
    //  2) С использованием сайта схемы (или http(s)://)
   
РаздС = Символы.ПС;
   
Ссылка_Запуск = ДанныеПереходаПоНавСсылке.БазоваяНавигационнаяСсылка;
   
Ссылка_Путь = ДанныеПереходаПоНавСсылке.ОтносительнаяНавигационнаяСсылка;
   
ПараметрN1 = ДанныеПереходаПоНавСсылке.ПараметрыНавигационнойСсылки.Получить("key1"); // Число: в URL глубинной ссылки

   
Доп_Данные = ДанныеПереходаПоНавСсылке.ДополнительныеДанныеПереходаВМобильноеПриложение;
   
ПараметрN2 = Доп_Данные.Получить("key2"); // Строка: описание вызова намерения (длина ограничена используемой ОС)

   
Текст_сообщения = "Старт запуска по ссылке:" + РаздС + " Cсылка: " + Ссылка_Запуск + РаздС +
   
"Относительный путь: " + Ссылка_Путь + РаздС + "Параметр N1: " + ПараметрN1 + РаздС + "Параметр N2: " + ПараметрN2;

   
Сообщить(Текст_сообщения);
   
СтандартнаяОбработка = Ложь;

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 29.09.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому