1С 8.3 Массив без дублей - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Массив без дублей

Данные > Примеры кода 1С > 1С 8.3 Массив
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Массив без дублей (от пользователя prog1c) в 1С 8.3:
Функция МассивБезДублей(ВходящийМассив) Экспорт

   ИсходящийМассив = Новый Массив;

   Если ЗначениеЗаполнено(ВходящийМассив) Тогда
       ТЗ = Новый ТаблицаЗначений;
       ТЗ.Колонки.Добавить("Данные");
       Для Сч = 1 По ВходящийМассив.Количество() Цикл
           ТЗ.Добавить();
       КонецЦикла;
       ТЗ.ЗагрузитьКолонку(ВходящийМассив, 0);
       ТЗ.Свернуть(ТЗ.Колонки[0].Имя);
       ИсходящийМассив = ТЗ.ВыгрузитьКолонку(0);
   КонецЕсли;

   Возврат ИсходящийМассив;

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 07.07.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому