1С 8.3 Константы - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Константы

Данные > Примеры кода 1С > 1С 8.3 Константы
Реклама:
Константы в 1С 8.3 это объект метаданных, используемый для хранения значений, которые или неизменны, или меняются редко. Например: "Название организации", "Юридический адрес", "Руководитель"... Увидеть весь список констант в режиме 1С Предприятие можно в разделе "Все функции" (если данный пункт меню недоступен, включить его можно в разделе Сервис - Параметры - Отображать команду Все функции).
Получение и установка значения константы в 1С 8.3:
&НаСервере
Процедура ПолучениеИУстановкаЗначенияКонстанты()

   
// создание менеджера значений и использование неявно
   
Сообщить(Константы.ОсновнойСклад.Получить());

   
Константы.ОсновнойСклад.Установить(Справочники.МестаХранения.НайтиПоНаименованию("Центральный склад г.Минск"));

КонецПроцедуры
Работа с константой через менеджер значений в 1С 8.3:
&НаСервере
Процедура РаботаСКонстантойЧерезМенеджерЗначений()

   
// создание и использование менеджера значений константы напрямую
   
ЭлектронныйАдрес = Константы.ЭлектронныйАдрес.СоздатьМенеджерЗначения();

   
// чтение значения константы
   
ЭлектронныйАдрес.Прочитать();
   
Сообщить(ЭлектронныйАдрес.Значение);

   
// замена значения константы
   
ЭлектронныйАдрес.Значение = Справочники.ЭлАдреса.НайтиПоРеквизиту("Email", "v83@1Cnik.by");

   
// запись значения константы
   
ЭлектронныйАдрес.Записать();

КонецПроцедуры
Работа с константами через набор в 1С 8.3:
&НаСервере
Процедура РаботаСКонстантамиЧерезНабор()

   
// подходит для работы с группой констант
   
НазванияКонстант = "ЭлектронныйАдрес, ОсновнойСклад";
   
НаборКонстант = Константы.СоздатьНабор(НазванияКонстант);

   
// чтение значения констант
   
НаборКонстант.Прочитать();
   
Сообщить(НаборКонстант.ЭлектронныйАдрес);
   
Сообщить(НаборКонстант.ОсновнойСклад);

   
// замена значения констант
   
НаборКонстант.ЭлектронныйАдрес = Справочники.ЭлАдреса.НайтиПоНаименованию("v77@1Cnik.by");
   
НаборКонстант.ОсновнойСклад = Справочники.МестаХранения.НайтиПоНаименованию("Склад г.Барановичи");

   
// запись значения констант
   
НаборКонстант.Записать();

КонецПроцедуры
Получение значений всех констант в цикле в 1С 8.3:
&НаСервере
Процедура ПолучениеЗначенийВсехКонстантВЦикле()

    Для Каждого
Константа Из Константы Цикл
       
Сообщить(СокрЛП(Константа.Получить())+ "/" +Строка(Константа));
    КонецЦикла;

КонецПроцедуры
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 29.03.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому