1С 8.3 Исключение записи пустого набора регистра сведений - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Исключение записи пустого набора регистра сведений

Данные > Примеры кода 1С > 1С 8.3 Регистры сведений
Реклама:
Перейти в раздел примеры кода 1С 8.3:
При изменении записи, набор записывается дважды, первый раз пустой, для удаления данных, второй раз для записи новых значений.
Пример "удаления" записи пустого набора регистра сведений в 1С 8.3:
Процедура ПередЗаписью(Отказ, Замещение)

   // Если идет запись пустого набора,
   // то в модуле записей регистра вызываем исключение,

   // удаление записей:
   Если ЭтотОбъект.Количество() = 0 И ЭтотОбъект.Модифицированность() = Истина Тогда
       //это пустой набор записей

       Если  НЕ РольДоступна("ПолныеПрава") Тогда
           Сообщить("Удаление запрещено. Нет прав.");
           Отказ = Истина;
       КонецЕсли;

     //ПользовательИБ = ПользователиИнформационнойБазы.ТекущийПользователь();
       //Если ПользовательИБ.Роли.Содержит("ПолныеПрава") Тогда
       //    Отказ = Истина;
       //    ВызватьИсключение("Удаление запрещено. Нет прав.");
       //КонецЕсли;

   КонецЕсли;
КонецПроцедуры
У наборов записей и менеджеров записи есть метод Модифицированность():
Если НаборЗаписей.Количество()=0 И НаборЗаписей.Модифицированность() Тогда
При добавлении новой записи:
НаборЗаписей.Количество() > 0 НаборЗаписей.Модифицированность() = Истина
При изменении записи:
НаборЗаписей.Количество() = 0 НаборЗаписей.Модифицированность() = Ложь
НаборЗаписей.Количество() > 0 НаборЗаписей.Модифицированность() = Истина
При удалении записи:
НаборЗаписей.Количество() = 0 НаборЗаписей.Модифицированность() = Истина
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 25.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому