1С 8.3 Если (оператор) - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Если (оператор)

Данные > Примеры кода 1С > 1С 8.3 Операторы > 1С 8.3 Оператор Если
Реклама:
Если в 1С 8.3 - это оператор который управляет выполнением программы, в зависимости от результата одного или более логических выражений. Оператор может содержать любое количество групп операторов, возглавляемых конструкциями "ИначеЕсли" - "Тогда". Оператор должен обязательно завершаться "КонецЕсли;".
Условие если (оператор) в 1С 8.3:
&НаКлиенте
Процедура УсловиеЕсли(Команда)

    Если
22 > 0 Тогда // Логическое выражение = Истина
       
Сообщить("Сработают команды в этом разделе условия");
    КонецЕсли;

   
//Двойное условие ИЛИ: 22 больше или равно 5
   
Если 22 >= 0 Тогда // Логическое выражение = Истина
       
Сообщить("Сработают команды в этом разделе условия");
    КонецЕсли;

   
//Двойное условие ИЛИ: 22 меньше или равно 5
   
Если 22 <= 0 Тогда // Не работает не одно условие
       
Сообщить("Не сработают команды");// Логическое выражение = Ложь
   
КонецЕсли;

   
//Двойное явное условие ИЛИ: 22 меньше или равно 5
   
Если (22 < 0) или (22 = 0) Тогда // Не работает не одно условие
       
Сообщить("Не сработают команды");// Логическое выражение = Ложь
   
КонецЕсли;

   
//Двойное явное условие И: 22 больше и равно 5
   
Если (22 > 0) и (22 = 0) Тогда // Не работает условие т.к. 22 не равно 0
       
Сообщить("Не сработают команды");// Логическое выражение = Ложь
   
КонецЕсли;

    Если
22 < 0 Тогда // Логическое выражение = Ложь
       
Сообщить("Не сработают команды");
    Иначе
       
Сообщить("Сработают команды в этом разделе условия");
    КонецЕсли;

    Если
22 < 0 Тогда // Логическое выражение = Ложь
       
Сообщить("Не сработают команды");
    ИначеЕсли
22 = 0 Тогда // Логическое выражение = Ложь
       
Сообщить("Не сработают команды");
    Иначе
       
Сообщить("Сработают команды в этом разделе условия");
    КонецЕсли;

КонецПроцедуры
Тернарное условие если (оператор) в 1С 8.3:
&НаКлиенте
Процедура ТернанрноеУсловиеЕсли(Команда)

   
ИнфоN1 = ?(22 > 5, "Сработают команды в этом разделе условия"" Логическое выражение = Ложь");
   
Сообщить(ИнфоN1); // сообщит "Сработают команды в этом разделе условия"

    //22 больше или равно 5
   
ИнфоN2 = ?(22 >= 5, "Сработают команды в этом разделе условия"" Логическое выражение = Ложь");
   
Сообщить(ИнфоN2); // сообщит "Сработают команды в этом разделе условия"

    //22 меньше или равно 5
   
ИнфоN3 = ?(22 <= 5, " Логическое выражение = Ложь", "Сработают команды в этом разделе условия");
   
Сообщить(ИнфоN3); // сообщит "Сработают команды в этом разделе условия"

КонецПроцедуры
Поиск кода
1
комментарий
новичок
12 фев 2021
вот тут всё понятно! а то нигде нет нормально описания
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 14.04.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому