1С 8.3 Добавление колонки в Таблица значений - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Добавление колонки в Таблица значений

Данные > Примеры кода 1С > 1С 8.3 Таблица значений
Реклама:
Перейти в раздел примеры кода 1С 8.3:
Добавление колонки (или обновление её свойств Заголовок и Ширина) в Таблица значений в 1С 8.3:
Функция Вставка_колонки_ТЗ(ТЗ, ИмяКолонки,
   
ТипКолонки = Неопределено, ЗаголовокКолонки = Неопределено, ШиринаКолонкки = Неопределено)

   
// Функция добавляет колонку в таблицу значений (если такой колонки нет)
    // или обновляет свойства Заголовок и Ширина (если такая колонка уже есть)

    //  ТЗ - "Таблица значений", в которую нужно добавить колонку
    //  ИмяКолонки - "Строка"
    //  ТипКолонки - "ОписаниеТипов, Неопределено" -
    //                Объект, описывающий типы значений для колонки
    //                (если параметр не указан, в колонке можно будет хранить значение любого типа)
    //  ЗаголовокКолонки - "Строка, Неопределено" - Заголовок колонки ТЗ
    //                      Используется при визуальном отображении таблицы значений.
    //  ШиринаКолонкки - "Строка, Неопределено" - Ширина колонки в символах для визуального отображения

   
КолонкаТЗ   = ТЗ.Колонки.Найти(ИмяКолонки);

    Если
КолонкаТЗ = Неопределено Тогда
       
КолонкаТЗ   = ТЗ.Колонки.Добавить(ИмяКолонки, ТипКолонки);
    КонецЕсли;

    Если
Заголовок <> Неопределено Тогда
       
КолонкаТЗ.Заголовок = Заголовок;
    КонецЕсли;

    Если
Ширина <> Неопределено Тогда
       
КолонкаТЗ.Ширина    = Ширина;
    КонецЕсли;

    Возврат
КолонкаТЗ; //добавленная (или найденная и обновленная колонка) колонка

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 16.04.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Защищенное соединение ssl
visa
mastercard
Maestro
Яндекс деньги
Назад к содержимому