1С 8.3 Чередование цвета строк в макете - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 Чередование цвета строк в макете

Реклама:
Перейти в раздел примеры кода 1С 8.3:
Построчно раскрасить макет в 1С 8.3:
Функция ПечатьРасчетнойВедомости(Данные, Вариант, ОтборПоПодразделениям)

   
ТабличныйДокумент = Новый ТабличныйДокумент;
   
Макет = ЭтотОбъект.ПолучитьМакет("ВедомостьНачисленияЗаработнойПлаты");

   
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
   
ТабличныйДокумент.Вывести(ОбластьШапка);

   
СписокСотрудников = ПолучитьСписокСотрудников(Данные);
   
тЦветной = 0;

    Для каждого
Сотрудник Из СписокСотрудников Цикл

       
ТабДокументТаблица = Новый ТабличныйДокумент;
       
ОбластьСтрока1 = Макет.ПолучитьОбласть("Строка");

        Если
тЦветной = 0 Тогда// Одну строку делаем белой, вторую - желтоватой (RGB)
           
тЦветФона   = Новый Цвет(255, 252, 227); // желтоватый
           
тЦветной = 1;
        Иначе
           
тЦветФона   = Новый Цвет(255, 255, 255); // белый
           
тЦветной = 0;
        КонецЕсли;

       
ОбластьОформления = ТабличныйДокумент.Вывести(ТабДокументТаблица);

        Если
РаскраскаТаблицы Тогда // Признак на форме:
            //Ложь - все останутся прозрачными (по умолчанию)
            //Истина - раскрасим
           
ТабличныйДокумент.Область(ОбластьОформления.Верх, ОбластьОформления.Лево,
           
ОбластьОформления.Низ, ОбластьОформления.Лево).ЦветФона = тЦветФона;
        КонецЕсли;

    КонецЦикла;

    Возврат
ТабличныйДокумент;

КонецФункции
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 27.05.2020
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому