1С 8.3 БСП УстановитьСостояниеПоляТабличногоДокумента - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП УстановитьСостояниеПоляТабличногоДокумента

Данные > Примеры кода 1С > 1С 8.3 БСП > Табличный документ
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП УстановитьСостояниеПоляТабличногоДокумента. Процедура управляет состоянием поля табличного документа.
Примера кода от rayastar
ОбщегоНазначенияКлиентСервер.УстановитьСостояниеПоляТабличногоДокумента(ПолеТабличногоДокумента, Состояние);

//
&НаКлиенте
Процедура СформироватьОтчет(Команда)

   РезультатВыполнения = СформироватьОтчетНаСервере();
   Если Не РезультатВыполнения.ЗаданиеВыполнено Тогда
       ДлительныеОперацииКлиент.ИнициализироватьПараметрыОбработчикаОжидания(ПараметрыОбработчикаОжидания);
       ПодключитьОбработчикОжидания("Подключаемый_ПроверитьВыполнениеЗадания", 1, Истина);
       ОбщегоНазначенияКлиентСервер.УстановитьСостояниеПоляТабличногоДокумента(Элементы.Результат, "ФормированиеОтчета");
   КонецЕсли;

КонецПроцедуры

//
&НаКлиенте
Процедура ДнейПланированияПриИзменении(Элемент)
   ОбщегоНазначенияКлиентСервер.УстановитьСостояниеПоляТабличногоДокумента(Элементы.Результат, "НеАктуальность");
КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 27.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому