1С 8.3 БСП СообщитьПрогресс - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП СообщитьПрогресс

Данные > Примеры кода 1С > 1С 8.3 БСП > Длительные операции
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП СообщитьПрогресс. Регистрирует информацию о ходе выполнения длительной операции. Во избежание избыточного потребления памяти и ее утечек при выполнении одной длительной операции не следует сообщать прогресс более 100 раз.
Примера кода от rayastar
ДлительныеОперации.СообщитьПрогресс(Процент, Текст, ДополнительныеПараметры)

//
Процедура РассчитатьПроцентВыгрузки(КоличествоВыгруженных, КоличествоОбъектовКВыгрузке) Экспорт

   // Сообщение о проценте выгрузки выдаем через каждые 100 объектов.
   Если КоличествоВыгруженных = 0 Или КоличествоВыгруженных / 100 <> Цел(КоличествоВыгруженных / 100) Тогда
       Возврат;
   КонецЕсли;

   Если КоличествоОбъектовКВыгрузке = 0 Или КоличествоВыгруженных > КоличествоОбъектовКВыгрузке Тогда
       ПроцентВыполнения = 95;
       Шаблон = НСтр("ru = 'Обработано: %1 объектов.'");
       Текст = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(Шаблон, Формат(КоличествоВыгруженных, "ЧН=0; ЧГ="));
   Иначе
       // 5% полосы резервируем под выгрузку по ссылкам, проценты по количеству считаем от 95.
       ПроцентВыполнения = Окр(Мин(КоличествоВыгруженных * 95 / КоличествоОбъектовКВыгрузке, 95));
       Шаблон = НСтр("ru = 'Обработано: %1 из %2 объектов.'");
       Текст = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
           Шаблон,
           Формат(КоличествоВыгруженных, "ЧН=0; ЧГ="),
           Формат(КоличествоОбъектовКВыгрузке, "ЧН=0; ЧГ="));
   КонецЕсли;

   // Регистрация сообщения для чтения из клиентского сеанса.
   ДополнительныеПараметры = Новый Структура;
   ДополнительныеПараметры.Вставить("ОбменДанными", Истина);

   ДлительныеОперации.СообщитьПрогресс(ПроцентВыполнения, Текст, ДополнительныеПараметры);
КонецПроцедуры;
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 12.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому