1С 8.3 БСП СообщенияПользователю - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП СообщенияПользователю

Данные > Примеры кода 1С > 1С 8.3 БСП > Длительные операции
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП СообщенияПользователю. Получает сообщения пользователю, отфильтровывает служебные сообщения о состоянии длительной операции.
Примера кода от rayastar
Операция = ДлительныеОперации.ВыполнитьВФоне(...);
...
Сообщения = ДлительныеОперации.СообщенияПользователю(Истина, Операция.ИдентификаторЗадания);

//
&НаСервере
Функция ПроверитьВыполнениеФоновогоЗаданияНаСервере()

   Попытка
       ЗаданиеВыполнено   = ДлительныеОперации.ЗаданиеВыполнено(ИдентификаторФоновогоЗадания);
       СообщенияОбОшибках = ДлительныеОперации.СообщенияПользователю(Ложь, ИдентификаторФоновогоЗадания);

       Для Каждого СообщениеОбОшибке Из СообщенияОбОшибках Цикл
           ТекстОшибки = ТекстОшибки + ?(ПустаяСтрока(ТекстОшибки), "", Символы.ПС) + СообщениеОбОшибке.Текст;
       КонецЦикла;
   Исключение
       ЗаголовокОшибки = НСтр("ru='Не удалось получить сведения хозяйствующего субъекта'");
       ТекстОшибки = СформироватьТекстОшибки(ЗаголовокОшибки, КраткоеПредставлениеОшибки(ИнформацияОбОшибке()));
       ЗаданиеВыполнено = Ложь;
   КонецПопытки;

   Если ПустаяСтрока(ТекстОшибки) Тогда
       Если ЗаданиеВыполнено Тогда
           ОбработатьРезультатВыполненияФоновогоЗадания();
       Иначе
           ОбработатьПрогрессВыполненияФоновогоЗадания();
       КонецЕсли;
   КонецЕсли;

   Возврат ЗаданиеВыполнено;

КонецФункции;
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 12.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому