1С 8.3 БСП ПрочитатьПрогресс - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП ПрочитатьПрогресс

Данные > Примеры кода 1С > 1С 8.3 БСП > Длительные операции
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП ПрочитатьПрогресс. Считывает информацию о ходе выполнения длительной операции, записанную процедурой ДлительныеОперации.СообщитьПрогресс.
Примера кода от rayastar
Результат = ДлительныеОперации.ПрочитатьПрогресс(ИдентификаторЗадания)

//
&НаСервереБезКонтекста
Функция ПроверитьВыполнениеИПрогрессЗадания(Знач ИдентификаторЗадания)

   РезультатВыполнения = Новый Структура();
   РезультатВыполнения.Вставить("ЗаданиеВыполнено",    Ложь);
   РезультатВыполнения.Вставить("Процент",             0);

   Если НЕ ЗначениеЗаполнено(ИдентификаторЗадания) Тогда
       РезультатВыполнения.ЗаданиеВыполнено     = Истина;
       РезультатВыполнения.Процент              = 100;
   Иначе
       Если ДлительныеОперации.ЗаданиеВыполнено(ИдентификаторЗадания) Тогда
           РезультатВыполнения.ЗаданиеВыполнено= Истина;
           РезультатВыполнения.Процент         = 100;
       Иначе
           ПередаваемоеЗначение = ДлительныеОперации.ПрочитатьПрогресс(ИдентификаторЗадания); // ПрочитатьПрогресс
           Если ТипЗнч(ПередаваемоеЗначение) = Тип("Структура")
               И ПередаваемоеЗначение.Свойство("Процент") Тогда
               РезультатВыполнения.Процент     = ПередаваемоеЗначение.Процент;
           КонецЕсли;
       КонецЕсли;
   КонецЕсли;

   Возврат РезультатВыполнения;

КонецФункции;
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 12.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому