1С 8.3 БСП ПолучитьРегламентноеЗадание - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП ПолучитьРегламентноеЗадание

Данные > Примеры кода 1С > 1С 8.3 БСП > Регламентные задания
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП ПолучитьРегламентноеЗадание. Возвращает РегламентноеЗадание из информационной базы.
Примера кода от rayastar
Результат = РегламентныеЗаданияСервер.ПолучитьРегламентноеЗадание(Идентификатор);

//
&НаСервере
Процедура УстановитьИспользованиеРегламентногоЗадания(Включено)

   Для Каждого ВыделеннаяСтрока Из Элементы.ТаблицаРегламентныеЗадания.ВыделенныеСтроки Цикл
       ТекущиеДанные = ТаблицаРегламентныеЗадания.НайтиПоИдентификатору(ВыделеннаяСтрока);
       Задание = РегламентныеЗаданияСервер.ПолучитьРегламентноеЗадание(ТекущиеДанные.Идентификатор);
       Если Задание.Использование <> Включено Тогда
           Задание.Использование = Включено;
           Задание.Записать();
           ТекущиеДанные.Использование = Включено;
       КонецЕсли;
   КонецЦикла;

КонецПроцедуры;
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 13.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому