1С 8.3 БСП ПараметрыВыполненияПроцедуры - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП ПараметрыВыполненияПроцедуры

Данные > Примеры кода 1С > 1С 8.3 БСП > Длительные операции
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП ПараметрыВыполненияПроцедуры. Конструктор коллекции ПараметрыВыполненияПроцедуры для функции ВыполнитьПроцедуру.
Примера кода от rayastar
Результат = ДлительныеОперации.ПараметрыВыполненияПроцедуры()

//
Процедура НачатьПроверкуСообщенийПоАктивностиПользователя(Приложение) Экспорт

   Если РегламентныеЗаданияСервер.РаботаСВнешнимиРесурсамиЗаблокирована() Тогда
       Возврат;
   КонецЕсли;

   Если Не РегистрыСведений.ОпросШиныМобильныхПриложений.ЗаписатьПотребность(Приложение, Ложь) Тогда
       Возврат;
   КонецЕсли;

   ПараметрыФоновогоВыполнения = ДлительныеОперации.ПараметрыВыполненияПроцедуры();
   ПараметрыФоновогоВыполнения.ОжидатьЗавершение           = 0;
   ПараметрыФоновогоВыполнения.ЗапуститьВФоне              = Истина;
   ПараметрыФоновогоВыполнения.КлючФоновогоЗадания         = Приложение;
   ПараметрыФоновогоВыполнения.НаименованиеФоновогоЗадания = СтрШаблон(
       НСтр("ru = 'Обработка сообщений мобильного приложения %1'", ОбщегоНазначения.КодОсновногоЯзыка()),
       Приложение);

   ДлительныеОперации.ВыполнитьПроцедуру(
       ПараметрыФоновогоВыполнения,
"ШинаМобильныхПриложений.ПроверитьСообщенияПриложения",
       Приложение);

КонецПроцедуры;
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 12.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому