1С 8.3 БСП ОжидатьЗавершение - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП ОжидатьЗавершение

Данные > Примеры кода 1С > 1С 8.3 БСП > Длительные операции
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП ОжидатьЗавершение. Ожидать завершения выполнения процедуры в фоновом задании и открыть форму ожидания длительной операции.
Примера кода от rayastar
ДлительныеОперацииКлиент.ОжидатьЗавершение(ДлительнаяОперация, ОповещениеОЗавершении, ПараметрыОжидания)

//
Процедура НачатьОжиданиеФормированияОтчета(Форма, ДлительнаяОперация, ОповещениеЗавершитьФормированиеОтчета) Экспорт

   Если ДлительнаяОперация = Неопределено Тогда
       Возврат;
   КонецЕсли;

   ПараметрыОжидания = ДлительныеОперацииКлиент.ПараметрыОжидания(Форма);

   ПараметрыОжидания.ВыводитьОкноОжидания = Ложь;
   ОбщегоНазначенияКлиентСервер.УстановитьСостояниеПоляТабличногоДокумента(Форма.Элементы.Результат, "ФормированиеОтчета");

   ОповещениеОЗавершении = Новый ОписаниеОповещения(
"ЗакончитьОжиданиеФормированияОтчета",
       ЭтотОбъект,
       ОповещениеЗавершитьФормированиеОтчета);
   ДлительныеОперацииКлиент.ОжидатьЗавершение(ДлительнаяОперация, ОповещениеОЗавершении, ПараметрыОжидания);

   // См. далее ЗакончитьОжиданиеФормированияОтчета

КонецПроцедуры

&НаКлиенте
Процедура ОбновитьСписокДокументовНаЭкспортЗавершение(ДлительнаяОперация, ДополнительныеПараметры) Экспорт

   Если ДлительнаяОперация = Неопределено Тогда // задание было отменено
       Возврат;
   КонецЕсли;

   Если ДлительнаяОперация.Статус = "Ошибка" Тогда
       ПоказатьОшибкуОбновленияДокументовНаЭкспортВФоне(ДлительнаяОперация);
   Иначе
       ЗагрузитьПлатежныеДокументыПослеОбновленияВФоне(ДлительнаяОперация);
   КонецЕсли;

   УправлениеФормой();

КонецПроцедуры;
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 12.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому