1С 8.3 БСП ОперативнаяПамятьДоступнаяКлиентскомуПриложению - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП ОперативнаяПамятьДоступнаяКлиентскомуПриложению

Данные > Примеры кода 1С > 1С 8.3 БСП > Текущее окружение
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП ОперативнаяПамятьДоступнаяКлиентскомуПриложению. Возвращает объем оперативной памяти, доступной клиентскому приложению.
Примера кода от rayastar
Результат = ОбщегоНазначения.ОперативнаяПамятьДоступнаяКлиентскомуПриложению()

Функция ЭтоМедленныйРежимРаботы() Экспорт

   ОперативнаяПамять    = ОбщегоНазначения.ОперативнаяПамятьДоступнаяКлиентскомуПриложению();
   РекомендуемыйОбъем   = ОбщегоНазначения.ОбщиеПараметрыБазовойФункциональности().РекомендуемыйОбъемОперативнойПамяти;

   ИБФайловая = (ОбщегоНазначения.ИнформационнаяБазаФайловая()
    И Не ОбщегоНазначения.КлиентПодключенЧерезВебСервер());

   // Проверка объема доступной оперативной памяти.
   Если ИБФайловая Тогда
       Если ЗначениеЗаполнено(ОперативнаяПамять)
           И ОперативнаяПамять < РекомендуемыйОбъем Тогда
           Возврат Истина;
       КонецЕсли;
   Иначе
       // В клиент-серверной базе данных проверим режим низкой скорости соединения.
       СкоростьТекущегоСоединения = ПолучитьСкоростьКлиентскогоСоединения();
       Возврат СкоростьТекущегоСоединения = СкоростьКлиентскогоСоединения.Низкая;
   КонецЕсли;

   Возврат Ложь;

КонецФункции
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 21.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому