1С 8.3 БСП НайтиЗадания - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП НайтиЗадания

Данные > Примеры кода 1С > 1С 8.3 БСП > Регламентные задания
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП НайтиЗадания. В локальном режиме работы возвращает регламентные задания, соответствующие отбору.
Примера кода от rayastar
Результат = РегламентныеЗаданияСервер.НайтиЗадания(Отбор)

//
Процедура ВыключитьЗадание(Организация)

   УстановитьПривилегированныйРежим(Истина);

   Отбор = Новый Структура();
   Отбор.Вставить("Метаданные", "ОтправкаОтчетностиВБанк");
   Задания = РегламентныеЗаданияСервер.НайтиЗадания(Отбор); // НайтиЗадания

   Для Каждого РегЗадание Из Задания Цикл
       Если РегЗадание.Параметры.Количество() > 0 И РегЗадание.Параметры[0] = Организация Тогда
           РегламентныеЗаданияСервер.УдалитьЗадание(РегЗадание);
       КонецЕсли;
   КонецЦикла;

   УстановитьПривилегированныйРежим(Ложь);

КонецПроцедуры;
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 13.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому