1С 8.3 БСП ЭтоWindowsКлиент - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП ЭтоWindowsКлиент

Данные > Примеры кода 1С > 1С 8.3 БСП > Текущее окружение
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП ЭтоWindowsКлиент. Возвращает Истина, если клиентское приложение запущено под управлением ОС Windows. Список функций, позволяющих определять где работает пользователь: ЭтоWindowsСервер(), ЭтоLinuxКлиент(), ЭтоLinuxСервер(), ЭтоMacOSКлиент(), ЭтоВебКлиент(), ЭтоМобильныйКлиент(), КлиентПодключенЧерезВебСервер().
Примера кода от rayastar
// Вызов с клиента
ОбщегоНазначенияКлиент.ЭтоWindowsКлиент()

// Вызов с серера
ОбщегоНазначения.ЭтоWindowsКлиент()


//
Функция УстановитьВнешнееСоединениеСБазой(Параметры) Экспорт

    #Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда
       ПодключениеНедоступно = ОбщегоНазначения.ЭтоLinuxСервер();
       КраткоеОписаниеОшибки = НСтр("ru = 'Прямое подключение к информационной базе недоступно на сервере под управлением ОС Linux.');
    #Иначе
       ПодключениеНедоступно = ЭтоLinuxКлиент() Или ЭтоOSXКлиент() Или ЭтоМобильныйКлиент();
       КраткоеОписаниеОшибки = НСтр("ru = 'Прямое подключение к информационной базе доступно только на клиенте под управлением ОС Windows.');
    #КонецЕсли

   Если ПодключениеНедоступно Тогда
       Результат.Соединение = Неопределено;
       Результат.КраткоеОписаниеОшибки = КраткоеОписаниеОшибки;
       Возврат Результат;
   КонецЕсли;

   Возврат Результат;

КонецФункции

//
&НаКлиенте
Процедура Печать(Команда)

   Если Не ОбщегоНазначенияКлиент.ЭтоWindowsКлиент() Тогда
       ПоказатьПредупреждение(, НСтр("ru = 'Печать файлов возможна только в Windows.'"));
       Возврат;
   КонецЕсли;

   РаботаСФайламиКлиент.НапечататьФайлы(ВыделенныеСтроки, ЭтотОбъект.УникальныйИдентификатор);

КонецПроцедуры
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 21.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому